Vacanta,vacantaaa

Posted: 12 Iunie 2011 in Lucruri simple

Si…Da!In sfarsit suntem atat de aproape de vacanta de vara.De acest paradis visat de toti copiii.Toti avem planuri de vacanta(realizabile sau mai putin realizabile) si vom uita de scoala pentru 3 luni,cufundandu-ne in lene.Dupa un an de scoala greu,dupa multe teme facute(sau nefacute),dupa nenumarate ascultari si o gama variata de note(de la cele mai mici la cele mai mari),dupa multe teste si teze,a venit vremea sa luam o pauza,sa ne relaxam si sa ne bucuram de fiecare zi de vacanta,care trece de fiecare data prea repede.Tot timpul mai ramane ceva nefacut,amanat pentru vacanta urmatoare…

In vacanta de vara intram cu zambetul pe buze,gandindu-ne la ce va urma si o parasim tot cu zambetul pe buze(de data asta un zambet mai timid)amintindu-ne de clipele frumoase petrecute alaturi de prieteni.Incepem scoala(desi nu suntem niciodata pregatiti pentru a o incepe,tot timpul vrem mai multa vacanta),dar nu putem sa nu ne gandim la….urmatoarea vacanta.

 

Oglinditul unui numar

Posted: 16 Noiembrie 2010 in Info
n c ogl
1472 2 2
147 7 27
14 4 274
1 1 2471

 

ogl=ogl*10+c

Pseudocod:

start

citeste n

ogl<-0

cat timp n!=0 executa

c<-n%10

n<-n/10

ogl<-ogl*10+c

scrie ogl

stop

Cifrele unui numar

Posted: 16 Noiembrie 2010 in Info

a)Enunt:se da un numar natural n.Se cere sa se afiseze cifrele numarului.

b)Exemplu

n c
1472 2
147 7
14 4
1 1
0  

c=n%10

n=n/10

c)Algoritmul suna cam asa:

-se citeste numarul

-cat timp n!=0 executa

             -aflam ultima cifra(c<-n%10)

             -eliminam ultima cifra(n<-n/10)

             -afisam cifra c

d)Pseudocod

start

citeste n

cat timp n!=0 executa

c<-n%10

n<-n/10

scrie c

stop

e)Observatii:Numarul n se modifica.Cifrele numarului se afla in ordine inversa:intai cifra unitatilor,apoi cifra zecilor,apoi cifra sutelor,apoi cifra miilor,apoi cifra zecilor de mii,apoi cifra sutelor de mii,apoi cifra milioanelor,apoi cifra zecilor de milioane,apoi cifra sutelor de milioane,apoi cifra miliardelor,etc.

CMMMC

Posted: 16 Noiembrie 2010 in Info

Pentru a calcula cmmmc a doua numere folosim algoritmul urmator:

start

citeste x,y

a<-x

b<-y

cat timp x!=y executa

     daca x<y atunci x<-x+a

     altfel y<-y+b

scrie x

stop

Sau putem folosi formula:cmmmc(a,b)=a*b/cmmdc(a,b)

🙂

De ce nu mai credem in povesti

Posted: 13 Noiembrie 2010 in Lucruri simple

E greu sa iti inchipui ca atunci cand eram mici ne incantau toate acele povesti nemuritoare,despre zane,sirene,balauri si altele…Acele povesti care ne purtau intr-o alta lume…Acele povesti care au reprezentat cheia dezvoltarii imaginatiei noastre.Atunci ne inchipuiam ca povestile sunt reale.Ca exista zane bune.Ca exista pestisori aurii care indeplinesc dorinte.Ca animalele pot sa vorbeasca.Ca exista baghete magice.Ca si noi putem invinge balauri.Dar astea sunt povesti…scrise de persoane cu o imaginatie extrem de bogata.Aceste povesti ne-au facut copilaria magica.Ne insoteau peste tot si cand a venit vremea sa citim singuri o carte,eram foarte mandri,desi abia am invatat alfabetul si mai mult silabiseam decat citeam.

Au trecut acele vremuri si am realizat ca povestile prezentau de fapt o realitate mult deformata…creata special pentru mintile inocente ale copiilor.Nu sunt minciuni…sunt adevaruri fantastice,realitati ideale,vise de neimplinit.

„Viata insasi este cel mai frumos basm.”(Hans Christian Andersen)

 

CMMDC(cel mai mare divizor comun)

Posted: 13 Noiembrie 2010 in Info

Cel mai mare divizor comun se poate calcula prin doua moduri:algoritmul prin scaderi repetate si algoritmul lui Euclid.

A.Algoritmul prin scaderi repetate

a)Enunt:se dau doua numere a si b.Se cere sa se determine cel mai mare divizor comun al lor.

b)Exemplu

  a b
90 42
48 42
6 42
6 36
6 24
6 18
6 12
6 6

cmmdc(90,42)=6

cmmdc(90,0)=90

cmmdc(0,80)=80

a=0=>cmmdc=b

b=0=>cmmdc=a

a*b=0=>cmmdc=a+b

c)Algoritmul

-citim a si b;

-daca a*b=0 scrie a+b

-altfel cat timp a!=b executa daca a>b atunci scade din a pe b altfel scade din b pe a;

-afiseaza a;

d)Pseudocod

start

citeste a,b

daca a*b=0 atunci scrie a+b

altfel cat timp a!=b executa

           daca a>b atunci a<-a-b

             altfel b<-b-a

scrie a

stop

e)Observatii

1.Numerele se modifica.Daca dorim sa folosim numerele dupa calculul cmmdc atunci trebuie sa le facem o copie(x<-a,y<-b)

2.Algoritmul este lent din punct de vedere al timpului.

B.Algoritmul lui Euclid

a)Enunt:se cere sa se calculeze cmmdc a doua numere.

b)Exemplu

a b r
50 78 50
78 50 28
50 28 22
28 22 6
22 6 4
6 4 2
4 2 0

 

c)Algoritmul

-citim a si b

-calculam restul r;r=a%b;

-cat timp r!=0 executa a=b,b=r,r=a%b;

scrie b

d)Pseudocodul

start

citeste a,b

r<-a%b

cat timp r!=0 executa

a=b

b=r

r=a%b

scrie b

stop

e)Observatii

1.In urma calcularii cmmdc,numerele se modifica.Pentru a le folosi apoi trebuie sa realizam o copie a lor.

2.Algoritmul lui Euclid este mai rapid decat algoritmul prin scaderi repetate pentru ca foloseste impartiri.

Fobii

Posted: 3 Noiembrie 2010 in Lucruri simple

Fobia poate fi caracterizata ca o frica de intensitate extrema, persistenta, irationala. Este cauzata de prezenta sau doar anticiparea prezentei unui obiect, a unei vietati sau a unei situatii.

Iata un top cu cele mai ciudate fobii!

1. Fobia de Papa

Desi multi asteapta sa fie binecuvantati de Papa, exista si oameni cu frica fata de Suveranul Pontif si chiar fata de catolicism. Fobia fata de Papa se manifesta prin accelerarea batailor inimii, palpitatii, cresterea frecventei respiratiilor sau greata.

2. Teama fata de untul de arahide lipit de cerul gurii

Ati citit bine! Sunt si oameni pentru care a manca un sandvis cu unt de arahide este o provocare, mai ales ca daca se si lipeste de cerul gurii.

3. Teama fata de par

Intri in panica atunci cand vezi fire de par pe haine sau pe covor? Transpiri si vezi fire de par peste tot? Clar, suferi de aceasta fobie.

4. Teama de a ramane fara acoperire la telefonul mobil

Simti ca esti pierdut atunci cand telefonul a ramas fara baterie sau atunci cand te afli intr-o zona fara acoperire? Diagnosticul e simplu! Te numeri printre cei care nu pot trai fara telefon, iar frica iti provoaca diferite senzatii – de la respiratie sacadata pana la stare de greata.

5. Fobia de adolescenti

Iti este frica ca adult sa interactionezi cu un adolescent? Atunci comportamentul tau in relatiile cu ei ar putea avea de suferit, o binevointa exagerata fiind rezultatul fobei fata de adolescenti.

6. Frica de a fi privit/privita

Cei care se simt stingheri sau chiar trec prin stari de panica atunci cand sunt priviti evita locurile aglomerate. De asemenea, nu se vor numara printre invitati la o petrecere. Pana si a conduce masina poate fi o incercare grea pentru cei care sufera de o astfel de fobie. Asta deoarece ei traiesc mereu cu senzatia ca sunt priviti, chiar daca realitatea ii contrazice.

7. Teama de oglinzi

Psihiatrii spun ca, de fapt, teama de cunoastere de sine are drept consecinta fobia fata de oglinzi.

8. Teama de a inghiti

Adesea, aceasta fobie este asociata cu teama de a manca sau de a pune kilograme in plus. Specialistii nu au putut stabili o cauza clara la originea acestei fobii.

9. Frica de a vomita

Cei care sufera de aceasta teama evita, de asemenea, sa manance, sa socializeze si chiar sa participe la petreceri. La unii, fobia se caracterizeaza prin absenta meselor si din acest motiv poti fi catalogati anorexici.

10. Frica de numarul 13

Aceasta teama poate fi asociata si superstitiei cum ca ziua de 13 este una mai putin favorabila. Pana si temutul Hitler avea o slabiciune fata de numarul 13.

Voi aveti fobii?Daca da,care sunt acestea?